Connect with us

Technology

Got an old iPhone or iPad? You need to install this security update now

Published

on

If you own an iPhone 5S, iPhone 6 or iPhone 6 Plus, you’re probably no longer in the habit of giving it software updates – but a new security update from Apple is an essential install if you want to keep your device secure.

A newly discovered vulnerability, which also affects some iPads (the iPad Air, iPad mini 2 and iPad mini 3), was recently picked up by Google’s Threat Analysis Group, potentially allowing attackers to trick affected users into visiting “maliciously crafted web content”. 

Continue Reading
Click to comment

Leave a Reply

Your email address will not be published. Required fields are marked *

Trending